Debian7(wheezy)をDebian8(jessie)にアップグレード。ついでにPHP7もインストール

本来はDebian8(jessie)を新規でインストールした方がいいに決まっているのですが、DTIの方で提供されていないのですから仕方ありません。

こちら

を参考にさせていただきました。
ただし、この方法では駄目みたいですよ。

ここ

にありますようにSystemdが邪魔して起動しなくなってしまうようです。
この件はまたあとで書くとして、まずはVMWareにて実験をしてみました。

まずはsudoとsshの設定

インストールしたてはまずはsudoとsshの設定ですね。

sudo

ルートになって作業します。

# vi /etc/sudoers
user ALL=(ALL:ALL) ALL

これでuserでsudoが使えるようになります。

ssh

$ sudo apt-get install ssh
$ sudo vi /etc/ssh/sshd_config
PermitRootLogin yes
↓
PermitRootLogin no
Port 22
↓(任意の番号に変更)
Port 9999
$ sudo service ssh restart

Debian7(wheezy)をDebian8(jessie)にアップグレード

1./etc/apt/sources.listを編集

もとにあったのはコメントにしてこれを追加します。

deb http://ftp.riken.jp/Linux/debian/debian/ jessie main
deb-src http://ftp.riken.jp/Linux/debian/debian/ jessie main
deb http://security.debian.org/ jessie/updates main
deb-src http://security.debian.org/ jessie/updates main
# jessie-updates, previously known as ‘volatile’
deb http://ftp.riken.jp/Linux/debian/debian/ jessie-updates main
deb-src http://ftp.riken.jp/Linux/debian/debian/ jessie-updates main
# PHP 7
deb http://packages.dotdeb.org jessie all

ついでにPHP7をインストールするためのリポジトリも追加しておきます。

2.apt-get update

警告が出た場合

apt-get install debian-archive-keyring

を実行します。VMWareでは警告が出ませんでした。

3.apt-get dist-upgrade

で、結構時間がかかりますが、アップグレードされます。
serversman@vps錠では関係ありませんが、結構UIも変わりますね。

バージョンを確認するにはこうします。

$ cat /etc/issue
Debian GNU/Linux 8 \n \l

PHP7をインストール

Debian8(jessie)に無事アップグレードできたらPHP7をインストールします。

1.dotdebのリポジトリの鍵情報をダウンロードして追加

$ wget https://www.dotdeb.org/dotdeb.gpg
$ sudo apt-key add dotdeb.gpg

2.インストール確認

$ sudo apt-get update

-sオプションを使って、php7がインストールできるようになったか確認します。

$ sudo apt-get -s install php
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています
状態情報を読み取っています... 完了
以下のパッケージが新たにインストールされます:
php
アップグレード: 0 個、新規インストール: 1 個、削除: 0 個、保留: 0 個。
Inst php (1:7.0+42-1~dotdeb+8.1 packages.dotdeb.org:jessie [all])
Conf php (1:7.0+42-1~dotdeb+8.1 packages.dotdeb.org:jessie [all])

3.インストール

php7を単独でインストールしようとするとapache2も入ってしまうそうです。
なので、こうします。ついでに、あとでwordpressをインストールするためのモジュールもいれてしまいましょう。

$ sudo apt-get install php7.0 php7.0-fpm php7.0-mysql php7.0-mbstring php7.0-xml php7.0-gd php7.0-curl

4.バージョン確認

バージョン確認して、おしまい!

$ php -v
PHP 7.0.25-1~dotdeb+8.1 (cli) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
with Zend OPcache v7.0.25-1~dotdeb+8.1, Copyright (c) 1999-2017, by Zend Technologies
スポンサーリンク







シェアする

  • このエントリーをはてなブックマークに追加

フォローする

スポンサーリンク